A Broadband and ADSL forum. BroadbanterBanter

Welcome to BroadbanterBanter.

You are currently viewing as a guest which gives you limited access to view most discussions and other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today.

Go Back   Home » BroadbanterBanter forum » Newsgroup Discussions » uk.telecom.voip (UK VOIP)
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

uk.telecom.voip (UK VOIP) (uk.telecom.voip) Discussion of topics relevant to packet based voice technologies including Voice over IP (VoIP), Fax over IP (FoIP), Voice over Frame Relay (VoFR), Voice over Broadband (VoB) and Voice on the Net (VoN) as well as service providers, hardware and software for use with these technologies. Advertising is not allowed.

Asterisk detecting POTS line hangup



 
 
Thread Tools Display Modes
  #1  
Old July 2nd 05, 11:58 PM posted to uk.telecom.voip
Sparks
external usenet poster
 
Posts: 68
Default Asterisk detecting POTS line hangup

I have a problem with my [email protected] where it does not detect the other
party (From the PSTN) clearing down.
Not a problem if they have just been talking to someone, as the user my side
of the asterisk box clearing down terminates the PSTN call too.
If the caller is in the voicemail system, leaves a message, then clears down
(Or calls, and clears down after one ring or so, asterisk does not realise
they have cleared down and records loads of silence or the usual
unobtainable tome you get.

I have included my configs below, if that helps!



zaptel.conf

# Span 1: WCFXO/0 "Wildcard X101P Board 1"
fxsks=1

# Span 2: WCFXO/1 "Wildcard X101P Board 2"
fxsks=2

# Global data

loadzone = uk
defaultzone = uk

***************************************
zaptel.conf

; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_ls
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=no
hidecallerid=no
callwaiting=no
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=no
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no
hanguponpolarityswitch=yes

;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include AMP configs
#include zapata_additional.conf

;Include genzaptelconf configs
#include zapata-auto.conf

**********************
zapata_additional.conf

[empty]

**********************
zapata-auto.conf

; Autogenerated by /usr/local/sbin/genzaptelconf -- do not hand edit
; Zaptel Channels Configurations (zapata.conf)
;
; This is not intended to be a complete zapata.conf. Rather, it is intended
; to be #include-d by /etc/zapata.conf that will include the global settings
;

; Span 1: WCFXO/0 "Wildcard X101P Board 1"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 1
context=from-pstn
group=0
channel = 1


; Span 2: WCFXO/1 "Wildcard X101P Board 2"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 2
context=from-pstn
group=0
channel = 2


  #2  
Old July 3rd 05, 12:57 AM posted to uk.telecom.voip
Ian
external usenet poster
 
Posts: 289
Default Asterisk detecting POTS line hangup

I have included my configs below, if that helps!



zaptel.conf

# Span 1: WCFXO/0 "Wildcard X101P Board 1"
fxsks=1

# Span 2: WCFXO/1 "Wildcard X101P Board 2"
fxsks=2

# Global data

loadzone = uk
defaultzone = uk

***************************************
zaptel.conf

; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_ls


this should be fxs_ks


rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=no
hidecallerid=no
callwaiting=no
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=no
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no
hanguponpolarityswitch=yes

Try it without this line ^






;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include AMP configs
#include zapata_additional.conf

;Include genzaptelconf configs
#include zapata-auto.conf

**********************
zapata_additional.conf

[empty]

**********************
zapata-auto.conf

; Autogenerated by /usr/local/sbin/genzaptelconf -- do not hand edit
; Zaptel Channels Configurations (zapata.conf)
;
; This is not intended to be a complete zapata.conf. Rather, it is

intended
; to be #include-d by /etc/zapata.conf that will include the global

settings
;

; Span 1: WCFXO/0 "Wildcard X101P Board 1"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 1
context=from-pstn
group=0
channel = 1


; Span 2: WCFXO/1 "Wildcard X101P Board 2"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 2
context=from-pstn
group=0
channel = 2


Hi try it with those changes, But as [email protected] uses non standard conf files there
could be others that may need changing , ie voicemail.conf

Good luck

Ian


  #3  
Old July 3rd 05, 02:12 AM posted to uk.telecom.voip
Sparks
external usenet poster
 
Posts: 68
Default Asterisk detecting POTS line hangup


signalling=fxs_ls


this should be fxs_ks


That's what it was origanally :-(


hanguponpolarityswitch=yes

Try it without this line ^


Again, somthing I added to *try* and fix it!



Hi try it with those changes, But as [email protected] uses non standard conf files
there could be others that may need changing , ie voicemail.conf


Thanks for the suggestions!

Sparks...


  #4  
Old July 3rd 05, 02:37 AM posted to uk.telecom.voip
Andrew Gabriel
external usenet poster
 
Posts: 223
Default Asterisk detecting POTS line hangup

In article ,
"Sparks" writes:
hanguponpolarityswitch=yes

Try it without this line ^


Again, somthing I added to *try* and fix it!


My SPA-3000 is configured for several methods to detect PSTN hang-up,
but the one that it always seems to pick up is the CPC Signal, which
is a momentary removal of voltage from the line, of something like
90-120ms IIRC. Sorry, no idea how you configure Asterisk to look for
this though.

--
Andrew Gabriel
  #5  
Old July 3rd 05, 11:06 AM posted to uk.telecom.voip
Ian
external usenet poster
 
Posts: 289
Default Asterisk detecting POTS line hangup

Hi ..


"Ian" spam"AT"bathfordhill.co.uk wrote in message
...
I have included my configs below, if that helps!



zaptel.conf

# Span 1: WCFXO/0 "Wildcard X101P Board 1"
fxsks=1

# Span 2: WCFXO/1 "Wildcard X101P Board 2"
fxsks=2

# Global data

loadzone = uk
defaultzone = uk

***************************************
zaptel.conf


This is a typo isnt it ? this sould be zapata.conf



; Zapata telephony interface
;
; Configuration file

[trunkgroups]

[channels]

language=en
context=from-pstn
signalling=fxs_ls



this should be fxs_ks as said before


rxwink=300 ; Atlas seems to use long (250ms) winks

comment this out ^

;



; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=no
hidecallerid=no
callwaiting=no
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=no
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no
hanguponpolarityswitch=yes

as before Try it without this line ^






;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include AMP configs
#include zapata_additional.conf

;Include genzaptelconf configs
#include zapata-auto.conf

**********************
zapata_additional.conf

[empty]

**********************
zapata-auto.conf

; Autogenerated by /usr/local/sbin/genzaptelconf -- do not hand edit
; Zaptel Channels Configurations (zapata.conf)
;
; This is not intended to be a complete zapata.conf. Rather, it is

intended
; to be #include-d by /etc/zapata.conf that will include the global

settings
;

; Span 1: WCFXO/0 "Wildcard X101P Board 1"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 1
context=from-pstn
group=0
channel = 1


; Span 2: WCFXO/1 "Wildcard X101P Board 2"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 2
context=from-pstn
group=0
channel = 2


Hi try it with those changes, But as [email protected] uses non standard conf files

there
could be others that may need changing , ie voicemail.conf


and here is a copy of a working zapata.conf


[channels]


language=en


context=incoming
signalling=fxs_ks

busydetect = yes
callprogress = no
busycount = 4
relaxdtmf = yes
callwaiting = yes
callwaitingcallerid = yes
threewaycalling = no
transfer = yes
cancallforward = yes
usedistinctiveringdetection = yes
callerid=asreceived


usecallerid = yes
cidsignalling = v23
cidstart = usehist

; UK BT Callsign ring patterns
dring1=366,246,216
dring2=246,98,0

dring1context=ringring_ringring
dring2context=ring_ring

echotraining = yes
echocancel = yes
echocancelwhenbridged = yes

musiconhold = default
immediate = no

;Fax detection
faxdetect=incoming
group=1
callgroup=1
pickupgroup=1
rxgain=1
txgain=4
channel = 1

Good luck

Ian




 




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
POTS in charge again 7 uk.telecom.broadband (UK broadband) 27 September 15th 05 10:27 PM
Broadband, POTS and VOIP question Peter uk.telecom.broadband (UK broadband) 18 December 12th 04 10:51 PM
HELP:PC Not Detecting Router - Telewest Joe uk.telecom.broadband (UK broadband) 6 November 12th 03 12:20 PM
POTS modem/ADSL ? Ian Stirling uk.telecom.broadband (UK broadband) 3 October 24th 03 06:08 PM
NTL Broadband and POTS Modem? Barry Higginbottom uk.telecom.broadband (UK broadband) 5 July 20th 03 03:47 PM


All times are GMT +1. The time now is 11:44 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 2.4.0
Copyright 2004-2018 BroadbanterBanter.
The comments are property of their posters.