A Broadband and ADSL forum. BroadbanterBanter

Welcome to BroadbanterBanter.

You are currently viewing as a guest which gives you limited access to view most discussions and other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today.

Go Back   Home » BroadbanterBanter forum » Newsgroup Discussions » uk.telecom.voip (UK VOIP)
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

uk.telecom.voip (UK VOIP) (uk.telecom.voip) Discussion of topics relevant to packet based voice technologies including Voice over IP (VoIP), Fax over IP (FoIP), Voice over Frame Relay (VoFR), Voice over Broadband (VoB) and Voice on the Net (VoN) as well as service providers, hardware and software for use with these technologies. Advertising is not allowed.

Nerd Vittles "Asteridex" Robodialler



 
 
Thread Tools Display Modes
  #1  
Old November 29th 05, 11:51 PM posted to uk.telecom.voip
Jono
external usenet poster
 
Posts: 209
Default Nerd Vittles "Asteridex" Robodialler

Hello.

I'm having some trouble with the most recent article @
http://mundy.org/blog/index.php?p=83

In particular this bit of code:

[from-internal-custom]
exten = _00.,1,SayDigits(${EXTEN:2},) ; extensions dialed with 00 prefix
get looked up in AsteriDex
exten = _00.,2,EAGI(asteridex.agi|${EXTEN})
exten = _00.,3,GotoIf($["${DIAL:0:2}" = "00?]?97)
exten = _00.,4,NoOp(Number to Dial: ${DIAL})
exten = _00.,5,NoOp(Person to Dial: ${DUDE})
exten = _00.,6,AGI(festival-script.pl|Connecting to: ${DUDE}. One moment
please.)
exten = _00.,7,Dial(IAX2/${DIAL}@sipdiscount,90,r)
exten = _00.,8,Hangup()
exten = _00.,97,Playback(num-not-in-db)
exten = _00.,98,Playback(goodbye)
exten = _00.,99,Hangup()

The article was written with [email protected] 1.5 in mind, I'm using v1.3.

I've got the webdialler (click to dial) all functioning properly, so I know
the numbers are stored in the database correctly, however with this part of
the application, I should be able to dial a short code, preceeded with 00 to
dial a contact.

Unfortunately, line 7 above seems to fail. When I dial one of the speed dial
codes, I hear two or three ringing tones, followed by a continuous tone and
the call never connects.


  #2  
Old November 30th 05, 11:08 PM posted to uk.telecom.voip
Ian
external usenet poster
 
Posts: 289
Default Nerd Vittles "Asteridex" Robodialler


"Jono" wrote in message
.uk...
Hello.

I'm having some trouble with the most recent article @
http://mundy.org/blog/index.php?p=83

In particular this bit of code:

[from-internal-custom]
exten = _00.,1,SayDigits(${EXTEN:2},) ; extensions dialed with 00 prefix
get looked up in AsteriDex
exten = _00.,2,EAGI(asteridex.agi|${EXTEN})
exten = _00.,3,GotoIf($["${DIAL:0:2}" = "00?]?97)
exten = _00.,4,NoOp(Number to Dial: ${DIAL})
exten = _00.,5,NoOp(Person to Dial: ${DUDE})
exten = _00.,6,AGI(festival-script.pl|Connecting to: ${DUDE}. One moment
please.)
exten = _00.,7,Dial(IAX2/${DIAL}@sipdiscount,90,r)
exten = _00.,8,Hangup()
exten = _00.,97,Playback(num-not-in-db)
exten = _00.,98,Playback(goodbye)
exten = _00.,99,Hangup()

The article was written with [email protected] 1.5 in mind, I'm using v1.3.

I've got the webdialler (click to dial) all functioning properly, so I

know
the numbers are stored in the database correctly, however with this part

of
the application, I should be able to dial a short code, preceeded with 00

to
dial a contact.

Unfortunately, line 7 above seems to fail. When I dial one of the speed

dial
codes, I hear two or three ringing tones, followed by a continuous tone

and
the call never connects.

Hi
what do you get on the * cli when the call fails ? Oh and I thought
sipiscount was sip not iax.

Ian


  #3  
Old November 30th 05, 11:41 PM posted to uk.telecom.voip
Jono
external usenet poster
 
Posts: 209
Default Nerd Vittles "Asteridex" Robodialler



Ian" spam"AT wrote:
|| "Jono" wrote in message
|| .uk...
||| Hello.
|||
||| I'm having some trouble with the most recent article @
||| http://mundy.org/blog/index.php?p=83
|||
||| In particular this bit of code:
|||
||| [from-internal-custom]
||| exten = _00.,1,SayDigits(${EXTEN:2},) ; extensions dialed with 00
||| prefix get looked up in AsteriDex
||| exten = _00.,2,EAGI(asteridex.agi|${EXTEN})
||| exten = _00.,3,GotoIf($["${DIAL:0:2}" = "00?]?97)
||| exten = _00.,4,NoOp(Number to Dial: ${DIAL})
||| exten = _00.,5,NoOp(Person to Dial: ${DUDE})
||| exten = _00.,6,AGI(festival-script.pl|Connecting to: ${DUDE}. One
||| moment please.)
||| exten = _00.,7,Dial(IAX2/${DIAL}@sipdiscount,90,r)
||| exten = _00.,8,Hangup()
||| exten = _00.,97,Playback(num-not-in-db)
||| exten = _00.,98,Playback(goodbye)
||| exten = _00.,99,Hangup()
|||
||| The article was written with [email protected] 1.5 in mind, I'm using
||| v1.3.
|||
||| I've got the webdialler (click to dial) all functioning properly, so
||| I know the numbers are stored in the database correctly, however with
||| this part of the application, I should be able to dial a short code,
||| preceeded with 00 to dial a contact.
|||
||| Unfortunately, line 7 above seems to fail. When I dial one of the
||| speed dial codes, I hear two or three ringing tones, followed by a
||| continuous tone and the call never connects.
|||
|| Hi
|| what do you get on the * cli when the call fails ?

Good question. Do I just log in at the console by entering asterisk -r?


|| Oh and I thought sipiscount was sip not iax.
||

You would've thought so, given its name, however I couldn't get it to work
successfully over sip, so ended up using iax.voipbuster.com as the
host............


  #4  
Old December 1st 05, 12:55 AM posted to uk.telecom.voip
Ian
external usenet poster
 
Posts: 289
Default Nerd Vittles "Asteridex" Robodialler


"Jono" wrote in message
. uk...


Ian" spam"AT wrote:
|| "Jono" wrote in message
|| .uk...
||| Hello.
|||
||| I'm having some trouble with the most recent article @
||| http://mundy.org/blog/index.php?p=83
|||
||| In particular this bit of code:
|||
||| [from-internal-custom]
||| exten = _00.,1,SayDigits(${EXTEN:2},) ; extensions dialed with 00
||| prefix get looked up in AsteriDex
||| exten = _00.,2,EAGI(asteridex.agi|${EXTEN})
||| exten = _00.,3,GotoIf($["${DIAL:0:2}" = "00?]?97)
||| exten = _00.,4,NoOp(Number to Dial: ${DIAL})
||| exten = _00.,5,NoOp(Person to Dial: ${DUDE})
||| exten = _00.,6,AGI(festival-script.pl|Connecting to: ${DUDE}. One
||| moment please.)
||| exten = _00.,7,Dial(IAX2/${DIAL}@sipdiscount,90,r)
||| exten = _00.,8,Hangup()
||| exten = _00.,97,Playback(num-not-in-db)
||| exten = _00.,98,Playback(goodbye)
||| exten = _00.,99,Hangup()
|||
||| The article was written with [email protected] 1.5 in mind, I'm using
||| v1.3.
|||
||| I've got the webdialler (click to dial) all functioning properly, so
||| I know the numbers are stored in the database correctly, however with
||| this part of the application, I should be able to dial a short code,
||| preceeded with 00 to dial a contact.
|||
||| Unfortunately, line 7 above seems to fail. When I dial one of the
||| speed dial codes, I hear two or three ringing tones, followed by a
||| continuous tone and the call never connects.
|||
|| Hi
|| what do you get on the * cli when the call fails ?

Good question. Do I just log in at the console by entering asterisk -r?

nearly "asterisk -vvvvvr" or asterisk -r then "set verbose 5"



|| Oh and I thought sipiscount was sip not iax.
||

You would've thought so, given its name, however I couldn't get it to work
successfully over sip, so ended up using iax.voipbuster.com as the
host............

fair enough


 




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SPEWS SLIMES "WindsorFox", "Kevin-!:?)", "Spin Dryer" get the cold shoulder at broadband ng! SneakyP uk.telecom.broadband (UK broadband) 0 November 29th 05 11:46 PM


All times are GMT +1. The time now is 11:23 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 2.4.0
Copyright 2004-2019 BroadbanterBanter.
The comments are property of their posters.