A Broadband and ADSL forum. BroadbanterBanter

Welcome to BroadbanterBanter.

You are currently viewing as a guest which gives you limited access to view most discussions and other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today.

Go Back   Home » BroadbanterBanter forum » Newsgroup Discussions » uk.telecom.voip (UK VOIP)
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

uk.telecom.voip (UK VOIP) (uk.telecom.voip) Discussion of topics relevant to packet based voice technologies including Voice over IP (VoIP), Fax over IP (FoIP), Voice over Frame Relay (VoFR), Voice over Broadband (VoB) and Voice on the Net (VoN) as well as service providers, hardware and software for use with these technologies. Advertising is not allowed.

Using two registries with Asterisk?



 
 
Thread Tools Display Modes
  #1  
Old June 2nd 06, 08:50 AM posted to uk.telecom.voip
Tinus
external usenet poster
 
Posts: 2
Default Using two registries with Asterisk?

Hello all,

I'm faily new to [email protected] I've got the latest version up and running.
In the netherlands I've got from my service provider 2 voip numbers (e.g.
0878700000 and 0878700001). The gateway is sip.xs4all.nl.

All is working perfectly when I only register 1 number (e.g. 0878700000). I
can make outbound calls and inbound calls are comming thru. But now I want
to use my second number: 0878700001

Below you see my sip.conf. With this configuration, only my last number:
0878700001works (last one in the sip.conf) If I comment out the entire
[xs4all-0878700001-out] block then my first number works: 0878700000.

I think this has something to do with the sip port 5060?

I test this configuration with 2 softphones (eyeBeam/X-Lite) installed on
separate machines. If I configure these softphone to register directly with
the sip gateway (of my ISP) then all works (inbound and outbound).

Hope someone here can help me with this. The ulimate goal is to let e.g.
extension 001 ring when someone calls the ..00 number and extension 002 when
someone calls the ..01 number and that ext. 002 dails out using the ..01
number etc.

Thanks in advance!

With regards,
Tinus

------------------------------
[general]
localnet=192.168.0.0/255.255.255.0
externip=83.23.45.2
bindport=5060
bindaddr=0.0.0.0
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=h263
allow=h263p
videosupport=yes
context = from-sip-external
callerid = Unknown

register = 0878700000 register = 0878700001
[xs4all-0878700000-out]
type=friend
context=from-xs4all-0878700000
nat=yes
host=sip.xs4all.nl
fromuser=0878700000
fromdomain=sip.xs4all.nl
username=0878700000
insecure=very
secret=password
canreinvite=no
dtmfmode=inband
qualify=yes
port=5060
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=h263
allow=h263p
restrictcid=no

[xs4all-0878700001-out]
type=friend
context=from-xs4all-0878700001
nat=yes
host=sip.xs4all.nl
fromuser=0878700001
fromdomain=sip.xs4all.nl
username=0878700001
insecure=very
secret=password
canreinvite=no
dtmfmode=inband
qualify=yes
port=5060
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=h263
allow=h263p
restrictcid=no
------------------------------


  #2  
Old June 2nd 06, 04:19 PM posted to uk.telecom.voip
Tinus
external usenet poster
 
Posts: 2
Default Using two registries with Asterisk?

Got it working already :-)

"Tinus" wrote in message
...
Hello all,

I'm faily new to [email protected] I've got the latest version up and
running. In the netherlands I've got from my service provider 2 voip
numbers (e.g. 0878700000 and 0878700001). The gateway is sip.xs4all.nl.

All is working perfectly when I only register 1 number (e.g. 0878700000).
I can make outbound calls and inbound calls are comming thru. But now I
want to use my second number: 0878700001

Below you see my sip.conf. With this configuration, only my last number:
0878700001works (last one in the sip.conf) If I comment out the entire
[xs4all-0878700001-out] block then my first number works: 0878700000.

I think this has something to do with the sip port 5060?

I test this configuration with 2 softphones (eyeBeam/X-Lite) installed on
separate machines. If I configure these softphone to register directly
with the sip gateway (of my ISP) then all works (inbound and outbound).

Hope someone here can help me with this. The ulimate goal is to let e.g.
extension 001 ring when someone calls the ..00 number and extension 002
when someone calls the ..01 number and that ext. 002 dails out using the
..01 number etc.

Thanks in advance!

With regards,
Tinus

------------------------------
[general]
localnet=192.168.0.0/255.255.255.0
externip=83.23.45.2
bindport=5060
bindaddr=0.0.0.0
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=h263
allow=h263p
videosupport=yes
context = from-sip-external
callerid = Unknown

register = 0878700000 register = 0878700001
[xs4all-0878700000-out]
type=friend
context=from-xs4all-0878700000
nat=yes
host=sip.xs4all.nl
fromuser=0878700000
fromdomain=sip.xs4all.nl
username=0878700000
insecure=very
secret=password
canreinvite=no
dtmfmode=inband
qualify=yes
port=5060
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=h263
allow=h263p
restrictcid=no

[xs4all-0878700001-out]
type=friend
context=from-xs4all-0878700001
nat=yes
host=sip.xs4all.nl
fromuser=0878700001
fromdomain=sip.xs4all.nl
username=0878700001
insecure=very
secret=password
canreinvite=no
dtmfmode=inband
qualify=yes
port=5060
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=h263
allow=h263p
restrictcid=no
------------------------------




 




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[email protected] {{{{{Welcome}}}}} uk.telecom.voip (UK VOIP) 7 April 22nd 06 10:37 PM
Getting started with Asterisk? dizzley uk.telecom.voip (UK VOIP) 4 April 20th 06 03:37 PM
BT Meridian 61C - Asterisk Brian Abbott uk.telecom.voip (UK VOIP) 0 January 31st 06 08:00 AM
Asterisk Help. Thomas Rankin uk.telecom.voip (UK VOIP) 2 October 26th 05 11:50 PM
Asterisk setup? Ian uk.telecom.voip (UK VOIP) 0 May 9th 05 05:36 PM


All times are GMT +1. The time now is 05:22 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 2.4.0
Copyright 2004-2019 BroadbanterBanter.
The comments are property of their posters.