A Broadband and ADSL forum. BroadbanterBanter

Welcome to BroadbanterBanter.

You are currently viewing as a guest which gives you limited access to view most discussions and other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today.

Go Back   Home » BroadbanterBanter forum » Newsgroup Discussions » uk.telecom.voip (UK VOIP)
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

uk.telecom.voip (UK VOIP) (uk.telecom.voip) Discussion of topics relevant to packet based voice technologies including Voice over IP (VoIP), Fax over IP (FoIP), Voice over Frame Relay (VoFR), Voice over Broadband (VoB) and Voice on the Net (VoN) as well as service providers, hardware and software for use with these technologies. Advertising is not allowed.

Sipgate with Trixbox



 
 
Thread Tools Display Modes
  #1  
Old August 4th 06, 03:36 PM posted to uk.telecom.voip
external usenet poster
 
Posts: n/a
Default Sipgate with Trixbox

Has anyone here got Sipgate working with Trixbox?

I am banging my head against a wall here!

If I call my Sipgate number form my normal phone, I am getting the message
(From my trixbox) "The number you have dialled is not in service, please
check the number and try again" beep beep beep etc...

From a fresh install I have done the following...

I was previously on the last build of [email protected] without problem

---------

In sip.conf, added the following...
externip=MY IP ADDRESS
outside_addr=MY IP ADDRESS

---------

Added my extensions, 200 and 201 - these can call each other.

---------

Added a new trunk with the following details (Copied from my working
[email protected] setup)

Outbound Caller ID - MY SIPGATE NUMBER
Max Channels - 1
Dial Rules - 0044+XXXXXXXXXX (Plus a load more other rules)
Trunk Name - Sipgate
PEER Details - allow=ulaw&alaw
authuser=SIPGATE ID
canreinvite=no
context=ext-did
disallow=all
dtmfmode=info
fromdomain=sipgate.co.uk
fromuser=SIPGATE ID
host=sipgate.co.uk
insecure=very
qualify=yes
secret=SIPGATE PASSWORD
type=peer
username=SIPGATE ID

Register String - SIPGATE /SIPGATE ID

--------------------

Inbound Routes

DID Number - SIPGATE ID

Destination - Office 200

-------------------


Any ideas what else I need to do!

Here is what the terminal spews out when I call my sipgate PSTN number from
a normal phone

(I have change my sipgate ID to MY SIPGATE ID)


-- Executing NoOp("SIP/gw02.uk.sipgate.net-09b0c6f8", "Received incoming
SIP connection from unknown peer to MY SIPGATE ID") in new stack
-- Executing Set("SIP/gw02.uk.sipgate.net-09b0c6f8", "DID=MY SIPGATE
ID") in new stack
-- Executing Goto("SIP/gw02.uk.sipgate.net-09b0c6f8", "s|1") in new
stack
-- Goto (from-sip-external,s,1)
-- Executing GotoIf("SIP/gw02.uk.sipgate.net-09b0c6f8", "0?from-trunk|MY
SIPGATE ID|1") in new stack
-- Executing Set("SIP/gw02.uk.sipgate.net-09b0c6f8",
"TIMEOUT(absolute)=15") in new stack
-- Channel will hangup at 2006-08-04 14:31:06 UTC.
-- Executing Answer("SIP/gw02.uk.sipgate.net-09b0c6f8", "") in new stack
-- Executing Wait("SIP/gw02.uk.sipgate.net-09b0c6f8", "2") in new stack
-- Executing Playback("SIP/gw02.uk.sipgate.net-09b0c6f8",
"ss-noservice") in new stack
-- Playing 'ss-noservice' (language 'en')
-- Executing Congestion("SIP/gw02.uk.sipgate.net-09b0c6f8", "") in new
stack

So the call is getting to asterisk, but it is refusing to route it!

Thanks!!

Sparks...


  #2  
Old August 4th 06, 05:32 PM posted to uk.telecom.voip
external usenet poster
 
Posts: n/a
Default Sipgate with Trixbox

"Sparks" wrote in message
...
Has anyone here got Sipgate working with Trixbox?


....I have now :-)

I had the go into the general settings page, and set the
"Allow Anonymous Inbound SIP Calls" to YES

Next problem...

I can dial in now, but can't seem to dial out!
It tells me the following...
(Dialed number changed to 888888)


-- Executing Macro("SIP/201-43c3", "dialout-trunk|2|888888||") in new
stack
-- Executing GotoIf("SIP/201-43c3", "1?3:2") in new stack
-- Goto (macro-dialout-trunk,s,3)
-- Executing Macro("SIP/201-43c3", "user-callerid") in new stack
-- Executing GotoIf("SIP/201-43c3", "0?report") in new stack
-- Executing GotoIf("SIP/201-43c3", "0?start") in new stack
-- Executing Set("SIP/201-43c3", "REALCALLERIDNUM=201") in new stack
-- Executing NoOp("SIP/201-43c3", "REALCALLERIDNUM is 201") in new stack
-- Executing Set("SIP/201-43c3", "AMPUSER=201") in new stack
-- Executing Set("SIP/201-43c3", "AMPUSERCIDNAME=Office") in new stack
-- Executing GotoIf("SIP/201-43c3", "0?report") in new stack
-- Executing Set("SIP/201-43c3", "CALLERID(all)=Office 201") in new
stack
-- Executing NoOp("SIP/201-43c3", "Using CallerID "Office" 201") in
new stack
-- Executing Macro("SIP/201-43c3", "record-enable|201|OUT") in new stack
-- Executing GotoIf("SIP/201-43c3", "0 0?2:4") in new stack
-- Goto (macro-record-enable,s,4)
-- Executing AGI("SIP/201-43c3",
"recordingcheck|20060804-172904|1154708944.4") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20060804-172904|1154708944.4: Outbound recording not
enabled
-- AGI Script recordingcheck completed, returning 0
-- Executing NoOp("SIP/201-43c3", "No recording needed") in new stack
-- Executing Macro("SIP/201-43c3", "outbound-callerid|2") in new stack
-- Executing GotoIf("SIP/201-43c3", "1?start") in new stack
-- Goto (macro-outbound-callerid,s,3)
-- Executing NoOp("SIP/201-43c3", "REALCALLERIDNUM is 201") in new stack
-- Executing Set("SIP/201-43c3", "USEROUTCID=") in new stack
-- Executing Set("SIP/201-43c3", "EMERGENCYCID=") in new stack
-- Executing Set("SIP/201-43c3", "TRUNKOUTCID=020777777") in new stack
-- Executing GotoIf("SIP/201-43c3", "1?trunkcid") in new stack
-- Goto (macro-outbound-callerid,s,11)
-- Executing GotoIf("SIP/201-43c3", "0?usercid") in new stack
-- Executing Set("SIP/201-43c3", "CALLERID(all)=020777777") in new stack
-- Executing GotoIf("SIP/201-43c3", "1?report") in new stack
-- Goto (macro-outbound-callerid,s,15)
-- Executing NoOp("SIP/201-43c3", "CallerID set to "" 020777777") in
new stack
-- Executing Set("SIP/201-43c3", "GROUP()=OUT_2") in new stack
-- Executing GotoIf("SIP/201-43c3", "0?108") in new stack
-- Executing Set("SIP/201-43c3", "DIAL_NUMBER=888888") in new stack
-- Executing Set("SIP/201-43c3", "DIAL_TRUNK=2") in new stack
-- Executing AGI("SIP/201-43c3", "fixlocalprefix") in new stack
-- Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
fixlocalprefix: Added prefix. New number: 00442088888888
-- AGI Script fixlocalprefix completed, returning 0
-- Executing Set("SIP/201-43c3", "OUTNUM=00442088888888") in new stack
-- Executing Set("SIP/201-43c3", "custom=SIP/Sipgate1") in new stack
-- Executing GotoIf("SIP/201-43c3", "0?16") in new stack
-- Executing Dial("SIP/201-43c3", "SIP/Sipgate1/00442088888888|120|r")
in new stack
== Everyone is busy/congested at this time (1:0/0/1)
-- Executing Goto("SIP/201-43c3", "s-CHANUNAVAIL|1") in new stack
-- Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
-- Executing NoOp("SIP/201-43c3", "Dial failed due to CHANUNAVAIL") in
new stack
-- Executing Macro("SIP/201-43c3", "outisbusy|") in new stack
-- Executing Playback("SIP/201-43c3", "all-circuits-busy-now") in new
stack
-- Playing 'all-circuits-busy-now' (language 'en')


  #3  
Old August 4th 06, 07:04 PM posted to uk.telecom.voip
external usenet poster
 
Posts: n/a
Default Sipgate with Trixbox


Sparks wrote:
Has anyone here got Sipgate working with Trixbox?

I am banging my head against a wall here!

If I call my Sipgate number form my normal phone, I am getting the message
(From my trixbox) "The number you have dialled is not in service, please
check the number and try again" beep beep beep etc...

From a fresh install I have done the following...

I was previously on the last build of [email protected] without problem

---------

In sip.conf, added the following...
externip=MY IP ADDRESS
outside_addr=MY IP ADDRESS

---------

Added my extensions, 200 and 201 - these can call each other.

---------

Added a new trunk with the following details (Copied from my working
[email protected] setup)

Outbound Caller ID - MY SIPGATE NUMBER
Max Channels - 1
Dial Rules - 0044+XXXXXXXXXX (Plus a load more other rules)
Trunk Name - Sipgate
PEER Details - allow=ulaw&alaw
authuser=SIPGATE ID
canreinvite=no
context=ext-did
disallow=all
dtmfmode=info
fromdomain=sipgate.co.uk
fromuser=SIPGATE ID
host=sipgate.co.uk
insecure=very
qualify=yes
secret=SIPGATE PASSWORD
type=peer
username=SIPGATE ID

Register String - SIPGATE /SIPGATE ID

--------------------

Inbound Routes

DID Number - SIPGATE ID

Destination - Office 200

-------------------


Any ideas what else I need to do!


My trixbox setup looks a bit different from yours, also you have a
couple of things I don't. Note: I only use Sipgate for an incoming
number as I use other providers for outgoing calls.

- my setup looks like this (where USERNAME is your sipgate ID):
Max Channels - blank
trunk name - sipgate
Peer details:
authuser=USERNAME
canreinvite=no
context=from-trunk
dtmfmode=info
fromdomain=sipgate.co.uk
fromuser=USERNAME
host=sipgate.co.uk
insecure=very
secret=PASSWORD
type=friend
username=USERNAME

INCOMING
Usercontext: USERNAME
USER Details:
context=from-trunk
dtmfmode=info
insecure=very
secret=PASSWORD
type=peer

Reg String /USERNAME
---
Inbound route - as you have it
DID: USERNAME
Destination: 200 or whatever

  #4  
Old August 4th 06, 10:33 PM posted to uk.telecom.voip
external usenet poster
 
Posts: n/a
Default Sipgate with Trixbox


"Sparks" wrote in message
...
Has anyone here got Sipgate working with Trixbox?



Yep. My sip_additional.conf looks like this:

[sipgate]
username=PASSWORD
type=friend
srvlookup=yes
secret=PASSWORD
qualify=no
qualify=yes
port=5060
nat=yes
insecure=very
host=sipgate.co.uk
fromuser=USERNAME
fromdomain=sipgate.co.uk
disable=all
context=from-trunk
bindaddr=0.0.0.0
allow=alaw
allow=ulaw
allow=g729
allow=gsm
allow=slinear

register=user
I just put everything (except the register string) in the first box (the
incoming box I think it was) - it doesn't matter. It still gets written to
the same sip_additional.conf.

remember to set "allow anonymous inbound SIP calls" in general, and set an
"ANY CID / ANY DID" inbound route.


  #5  
Old August 4th 06, 10:40 PM posted to uk.telecom.voip
external usenet poster
 
Posts: n/a
Default Sipgate with Trixbox


"Carl Farrington" wrote
in message ...

"Sparks" wrote in message
...
Has anyone here got Sipgate working with Trixbox?



Yep. My sip_additional.conf looks like this:

[sipgate]
username=PASSWORD


^^^ oops, that should of course be USERNAME. :blush:


 




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
First Foray into Trixbox Telephoneman uk.telecom.voip (UK VOIP) 11 August 2nd 06 04:28 PM
Babble on Trixbox / Asterisk paul123 uk.telecom.voip (UK VOIP) 0 July 20th 06 10:19 AM
Trixbox & Voipfone RH uk.telecom.voip (UK VOIP) 4 July 11th 06 10:40 AM
Asterisk @ Home / Trixbox Dial Rules sean uk.telecom.voip (UK VOIP) 9 June 6th 06 07:19 PM
Sipgate: dialing another sipgate number Stuart Millington uk.telecom.voip (UK VOIP) 7 June 14th 05 06:25 PM


All times are GMT +1. The time now is 04:48 AM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 2.4.0
Copyright 2004-2020 BroadbanterBanter.
The comments are property of their posters.