A Broadband and ADSL forum. BroadbanterBanter

Welcome to BroadbanterBanter.

You are currently viewing as a guest which gives you limited access to view most discussions and other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today.

Go Back   Home » BroadbanterBanter forum » Newsgroup Discussions » uk.telecom.voip (UK VOIP)
Site Map Home Register Authors List Search Today's Posts Mark Forums Read Web Partners

uk.telecom.voip (UK VOIP) (uk.telecom.voip) Discussion of topics relevant to packet based voice technologies including Voice over IP (VoIP), Fax over IP (FoIP), Voice over Frame Relay (VoFR), Voice over Broadband (VoB) and Voice on the Net (VoN) as well as service providers, hardware and software for use with these technologies. Advertising is not allowed.

Asterisk/Trixbox not reporting correct status of extensions



 
 
Thread Tools Display Modes
  #1  
Old November 7th 06, 06:13 PM posted to uk.telecom.voip
Dan
external usenet poster
 
Posts: 2
Default Asterisk/Trixbox not reporting correct status of extensions

Dear All,

Really simple setup, no manual conf file changes, just a box running
trixbox with two extensions (Polycom 301s) using NAT (done by
FireBrick) - no connection to the outside world, just internal calls
for now.

All works fine for first call in each session, with the phone
registering as available. However, once a call has been made, the phone
becomes unavailable and all subsiquent calls to that extension getting
shoved to voicemail (busy) and the status reporting as unavailable. It
is like the phone system doesn't know that the call has terminated.
Happens the same if softphones are used (SJPhone on OSX). Call
durations are reporting correctly.

Any ideas? Everything has gone so smoothly (so far).

I would be really greatful for your advice on this one - two of us have
speant all day on it without so much as an inch of progress!

Thanks,

Dan

  #2  
Old November 8th 06, 09:03 PM posted to uk.telecom.voip
alexd
external usenet poster
 
Posts: 331
Default Asterisk/Trixbox not reporting correct status of extensions

Dan wrote:

Dear All,

Really simple setup, no manual conf file changes, just a box running
trixbox with two extensions (Polycom 301s)


Ah yes, the perpetual beta that is Trixbox ;-) Which version of Trixbox? Are
your Polycoms on the latest firmware?

using NAT (done by FireBrick) - no connection to the outside world, just
internal calls for now.


Are you saying that the FireBrick is doing NAT between the Polycoms and the
Asterisk box? If that's the case, I'd eliminate the NAT first and confirm
it works without that.

All works fine for first call in each session, with the phone
registering as available. However, once a call has been made, the phone
becomes unavailable and all subsiquent calls to that extension getting
shoved to voicemail (busy) and the status reporting as unavailable. It
is like the phone system doesn't know that the call has terminated.


What does the Flash Operator Panel say? [although on 1.1.1 FOP server seems
to need restarting on a regular basis as it gets out of sync].

Happens the same if softphones are used (SJPhone on OSX). Call
durations are reporting correctly.

Any ideas?


Log into an asterisk shell with 'asterisk -rc'. Then type
'sip show channels'. This will show you any active SIP calls [I presume
you're using SIP].

--
http://ale.cx/ (AIM:troffasky) )
20:32:54 up 15 days, 4:18, 3 users, load average: 3.02, 3.06, 3.06
This is my BOOOOOOOOOOOOOOOOOOOOOMSTICK

  #3  
Old November 9th 06, 05:51 PM posted to uk.telecom.voip
Dan
external usenet poster
 
Posts: 2
Default Asterisk/Trixbox not reporting correct status of extensions


alexd wrote:

Dan wrote:

Dear All,

Really simple setup, no manual conf file changes, just a box running
trixbox with two extensions (Polycom 301s)


Ah yes, the perpetual beta that is Trixbox ;-) Which version of Trixbox? Are
your Polycoms on the latest firmware?

using NAT (done by FireBrick) - no connection to the outside world, just
internal calls for now.


Are you saying that the FireBrick is doing NAT between the Polycoms and the
Asterisk box? If that's the case, I'd eliminate the NAT first and confirm
it works without that.

All works fine for first call in each session, with the phone
registering as available. However, once a call has been made, the phone
becomes unavailable and all subsiquent calls to that extension getting
shoved to voicemail (busy) and the status reporting as unavailable. It
is like the phone system doesn't know that the call has terminated.


What does the Flash Operator Panel say? [although on 1.1.1 FOP server seems
to need restarting on a regular basis as it gets out of sync].

Happens the same if softphones are used (SJPhone on OSX). Call
durations are reporting correctly.

Any ideas?


Log into an asterisk shell with 'asterisk -rc'. Then type
'sip show channels'. This will show you any active SIP calls [I presume
you're using SIP].



Thanks very much for your help... I did what you suggested and brought
it back inside the network... it was a NAT issue, and the polycom
handsets don't support keep-alive! My good chap Ray sorted it with a
little bit of beer and a lot of shouting. Works like a treat now!

Thanks very much again,

Dan

 




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Babble on Trixbox / Asterisk paul123 uk.telecom.voip (UK VOIP) 0 July 20th 06 10:19 AM
Asterisk @ Home / Trixbox Dial Rules sean uk.telecom.voip (UK VOIP) 9 June 6th 06 07:19 PM
Query: Reporting line noise David G. Bell uk.telecom.broadband (UK broadband) 1 August 13th 05 08:55 AM
How many extensions off one filter? Iain uk.telecom.broadband (UK broadband) 8 July 24th 05 08:15 AM
Too many extensions? ChrisR uk.telecom.broadband (UK broadband) 7 October 8th 04 06:10 PM


All times are GMT +1. The time now is 12:03 PM.


Powered by vBulletin® Version 3.6.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.Content Relevant URLs by vBSEO 2.4.0
Copyright 2004-2019 BroadbanterBanter.
The comments are property of their posters.